Is anyone having connection issues with this site?

Discussion in 'The Pool Room' started by Scruff, 7 November 2019.

  1. Scruff

    Scruff Well-Known Member

    Joined:
    25 July 2018
    Messages:
    755
    Likes Received:
    119
    For several weeks now, I am constantly having pages here just show "connecting..." and taking an age to load. This is becoming more and more regular and persists for a while before pages start loading normally again. Quite frankly, the site is becoming more and more unusable as time goes on.

    Is anyone else experiencing this issue?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Atticus

    Atticus Well-Known Member

    Joined:
    6 February 2019
    Messages:
    466
    Likes Received:
    86
    Yep... I've noticed it a fair bit more of late... Keep thinking it's my wifi or Internet connection... change to 4G & still the same
     
  3. Scruff

    Scruff Well-Known Member

    Joined:
    25 July 2018
    Messages:
    755
    Likes Received:
    119
    It's definately a problem with this site and these days it's happening several times an hour. It's getting worse and worse.
    Over the last few days, I've been opening up other sites immediately when the problem happens and they all load normally, so it's not anything at my end.
    I'm betting it's that CloudFlare rubbish that's causing all the problems. I've seen similar issues with other sites that use it too.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Scruff

    Scruff Well-Known Member

    Joined:
    25 July 2018
    Messages:
    755
    Likes Received:
    119
    Bloody hell - now I'm getting CloudFlare boxes popping up saying "connection timed out" while I'm typing a post.

    This is beyond a joke now.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Atticus

    Atticus Well-Known Member

    Joined:
    6 February 2019
    Messages:
    466
    Likes Received:
    86
    Same here.... Haven't had the timed out message as yet
     
  6. lawanswers

    lawanswers Moderator
    Staff Member

    Joined:
    6 April 2014
    Messages:
    100
    Likes Received:
    58
    Apologies, I have escalated to Cloudflare and will keep you updated.
     
    Joshbuck likes this.
  7. lawanswers

    lawanswers Moderator
    Staff Member

    Joined:
    6 April 2014
    Messages:
    100
    Likes Received:
    58
    @Scruff and @Atticus - I have purged all caches in CloudFlare, etc. This means that it may be temporarily (next 1-2 hours) a bit slower than normal to access - but hopefully it resolves the Cloudflare CDN speed issues.
     
  8. Scruff

    Scruff Well-Known Member

    Joined:
    25 July 2018
    Messages:
    755
    Likes Received:
    119
    @lawanswers - Still happening. Just opened the Commercial Law forum from the home page and the browser was stuck trying to connect for over 40 seconds (6:21PM). This page then loaded straight away.

    I think you need to look at the DNS settings. I just looked them up at MxToolbox and the TTL (Time To Live) setting is 30 seconds - that's way too short. It should be at least 5 minutes. If your server has a static IP address (which it should), then there's no reason for a TTL of under 1 hour, in fact, I recommend 24 hours to reduce DNS server load.

    A TTL of 30 seconds is causing way too many DNS lookups and it appears that the DNS servers are choking on it. I think this is what's causing the connection problems.

    (FYI - I have several I.T. qualifications, including Networking.)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. lawanswers

    lawanswers Moderator
    Staff Member

    Joined:
    6 April 2014
    Messages:
    100
    Likes Received:
    58
    Hi @Scruff - Yes, I understand 5 minutes/300 seconds is a common setting. 30 seconds is set by Cloudflare. Have escalated again to their support. Thank you for your patience.
     
    Scruff likes this.
  10. lawanswers

    lawanswers Moderator
    Staff Member

    Joined:
    6 April 2014
    Messages:
    100
    Likes Received:
    58
    Hi @Scruff - I've just received an update from Cloudflare (almost one month - despite LawAnswers.com.au using Cloudflare's paid service):
    Looks better on my end - Network Tools: DNS,IP,Email
     
    #10 lawanswers, 4 December 2019 at 5:37 PM
    Last edited: 4 December 2019 at 5:46 PM
Loading...
Similar Threads - anyone having connection
  1. Scruff
    Replies:
    0
    Views:
    378

Share This Page

Loading...
gt;